美国服务器_我的世界rpg服务器_代金券

2021-05-05 03:31

新版本的saps/4hanacloudsdkjava库从今天开始提供。您可以将依赖项更新到版本2.7.0,并使用Maven Central的新版本。在这篇博文中,我们将带您了解本版本的亮点。要获得完整的概述,请访问我们的Java库发行说明。发行说明还包括到目前为止我们所有发行版的更改日志。在文章的最后,您将看到一组关于如何更新到新版本的说明。

关于SAP S/4HANA Cloud SDK的openSAP课程将在不到一周的时间内开始。今天别忘了注册!从下周三(11月14日)开始,您将学习使用SAP S/4HANA Cloud SDK为SAP S/4HANA构建和交付云本机扩展的所有知识。

作为一种特殊待遇和奖励,最终课程分数最高的35名课程完成者将获得我们的《扩展SAP S/4HANA》一书的免费副本!所以不要错过这个机会,从第一天开始就参加。更多详细信息,请参阅我们的博客文章。

版本2.7.0主要是一个维护版本,有一些错误修复,列在完整的发行说明中。例如,我们修复了Java虚拟数据模型(VDM)中的一个bug,在这个bug中,网站自助建站系统,对orderBy的多次调用将导致查询只包含最后一个方法调用的排序表达式。现在,请求将根据调用方法的顺序正确地链接顺序表达式。

版本2.7.0的一个新功能是能够将一个请求上下文包装到另一个请求上下文中。RequestContext保存有关当前请求上下文的中心信息,例如当前租户、目的地以及通过SDK的访问器类访问的其他信息。在引入新功能之前,只能有一个请求上下文(自动创建或手动启动),不能嵌套。某些场景可能需要在请求上下文已经存在的情况下启动新的请求上下文(使用RequestContextExecutor),例如,切换租户上下文。现在,您可以在配置RequestContextExecutor时显式指定请求上下文已经存在。执行器将在新的请求上下文中执行包装的代码,然后恢复到父上下文。默认情况下,这是禁用的,嵌套将引发异常。必须使用withParentRequestContext()方法显式启用此功能:

完整发行说明中列出了一些进一步的改进和错误修复,例如,企业软件公司,在审核日志记录方面。

要更新现有项目中使用的SAP S/4HANA Cloud SDK Java库的版本,淘客联盟,请按以下步骤进行:

打开pom.xml文件文件位于项目的根文件夹中。找到dependency management部分,阿里大数据应用平台,淘客文案,并在其中找到sdkbom依赖项。将依赖项的版本更新到2.7.0.

这样,您就可以使用"物料清单"(BOM)方法了。您的依赖关系应该是这样的:

您现在可以重新编译您的项目(注意兼容性说明),并利用2.7.0版中SAP S/4HANA Cloud SDK的新功能。

当然,您也可以通过运行Maven archetypes for Neo或Cloud Foundry来生成一个从一开始就使用2.7.0版的新项目-DarchetypeVersion=2.7.0(或发行版)。

分享到:
收藏
相关阅读