微软云_斗破苍穹电视剧全集百度云_免费1年

2021-05-05 15:00

目录01 Oracle虚拟盒02 VMWare Workstation播放器03其他环境04其他Linux发行版05使用ABAP06使用SAP ASE数据库07下载/提取错误08安装错误09参考资料

这是我从asabap开发版和社区反馈中收集的非正式信息。此处的信息和链接未经SAP认可–使用此项风险自负。

我可以从不同的计算机连接到我的服务器吗?

是的。但是,如果您想查看虚拟机,则需要使用桥接网络。可能值得一看Oracle虚拟盒手册,但这对我很有用:

vhcalnplcivhcalnplci.dummy.nodomain域

改回NAT:

127.0.0.1 localhost

10.0.2.15vhcalnplci.dummy.nodomain域vhcalnplci

更多信息:VBox指南6.5.

我可以将虚拟机从一个驱动器移动到另一个驱动器吗?

https://forums.virtualbox.org/viewtopic.php?f=35&t=55003–官方指南

https://dirkstrauss.com/moving-virtualbox-vm/–第三方指南–自担风险使用,但我发现截图等更好

视频:有我可以看的视频指南吗?

是的!社区成员PawełWiejkuthas还制作了一个视频:在Oracle Virtual Box和openSUSE Leap 15.1上安装为ABAP 7.5x

高级提示:缩小VirtualBox VDI磁盘映像

请参阅Tobias Hofmann的指南(第三方内容-使用风险自负):

缩小VirtualBox VDI磁盘映像

将虚拟机从一个驱动器/位置复制到另一个位置另一个

不幸的是,你应该使用工作站(不是免费的),而不是播放器。我遵循了这个非正式的指南,但这样做是你自己的风险:

https://www.htpcguides.com/workaround-to-clone-vmplayer-virtual-machines/

将VirtualBox文件转换为与VMWare Player一起使用

完成后,您将收到一条成功消息,真正云服务器,您仍然需要进行以下SAP特定设置:

IP地址,Vbox=10.0.2.15IP地址,VMWare=egnnn.nnn.nnn.nnn(检查ifconfig–in hosts(Linux);hosts(Win);SAPGUI

将虚拟机从一个驱动器移动到另一个驱动器

https://communities.vmware.com/thread/466994–论坛线程–自担风险使用

这些是社区成员的提示,他们尝试了非默认配置。他们都有自己的风险。我没有测试它们。

Docker

Dockerfile for AS ABAP 7.5x,作者:Tobias Hofmann。

Fusion,VMWare Fusion for Mac

NEW:Mac上开发版本的第一个文档。感谢同事Faaiez Sallie:

在VMWare Fusion for Mac(pdf)中安装为ABAP 7.52 SP04

谷歌云平台

在GCP上安装SAP NetWeaver作为ABAP Developer Edition 7.52 SP04,附带一个帮助程序VM–详细、冗长,迪伦·德拉蒙德非常有趣的博客文章:

https://sap-on-gcp.blogspot.com/2020/09/blog-post.html

Hyper-V

安装为带有Hyper-V/openSUSE Leap的ABAP开发版本

(带有openSUSE Leap,默认情况下)

Fabian Lupa的详细指南

Parallels Desktop 14

as ABAP 7.52 SP 01 Developer Edition on Debian 9 in Parallels Desktop 14

(with Debian 9)

Dominik Di Lorenzo的详细指南

Vagrant(云存储库)

https://github.com/sbcgua/sap-nw-abap-vagrant

同样,我还没有测试过这个,但是看起来很棒。Vagrant是一个[命令行]工具,可以使用脚本方便地设置虚拟环境。

Alexander Tsybulsky写了一篇关于这个的博客文章:用Vagrant和Ubuntu安装为ABAPChristian Weiss在openSUSE 15.1、42.3和42.1上提供ABAP 7.52版本。他还写了一篇详细的博客文章:用Vagrant和openSUSE将NetWeaver安装为ABAP 7.xx开发版

同样,这些是社区成员的提示,他们已经试用了非默认的Linux发行版。他们都有自己的风险。我没有测试过它们。

CentOS 7

这是一个社区成员测试过的。但是,根据他的说法,必须正确设置SHMMAX和SHMALL。有关更多信息,请参阅CentOS 7 docu.

Debian 9

AS ABAP 7.52 SP 01 Developer Edition on Debian 9 in Parallels Desktop 14

(on Parallels Desktop 14)

作者:Dominik Di Lorenzo

Ubuntu 1604 LTS–1910

简明指南在Ubuntu VM上安装SAP NetWeaver Developer Edition

作者:dylan drummond

abapGIT:可以吗使用?

简而言之,abapGIT是用ABAP为ABAP编写的GIT客户端。它为开发人员提供了一种简单的方法,可以将他们的ABAP开发对象上传到一个开放的Git站点,或者将其他人感兴趣的开发对象导入到一个开放的Git站点。这真的很简单。

关注这个博客,双线服务器租用,安装工具和将示例包克隆到开发人员版本的端到端指南:https://blogs.sap.com/2017/06/21/abapgit-so-easy/(GrahamRobbo)

更新:abapGit现在可用于ABAP开发工具(即Eclipse):

有一个有用的项目集合此处:

SAP Business Suite/ERP/S/4HANA内容:我可以访问吗?

…包括像BAKR这样的ERP开发对象,或者像VA01这样的事务?

不,不能。开发者版中没有套件内容。

开发者版旨在让人们了解更多关于ABAP语言和工具的知识。它不是针对那些想了解业务应用程序,如S/4HANA或business Suite的人。

但是:

SAP business Warehouse,为

配置NPL请参阅PawełWiejkut的博客:

为SAP BW开发准备NPL

SAP Cloud Connector

分享到:
收藏
相关阅读